How to Install Python 3.8 on Ubuntu, Debian and LinuxMint

The Python team has released its latest version Python 3.8 for general use. You can download the latest stable version Python 3.8 series and install it on your system. This article will help you to install Python 3.8.0 on Ubuntu, Debian, and LinuxMint operating system. You can visit here to read more about Python releases.

Step 1 – Prerequsitis

As you are going to install Python 3.8 from the source. You need to install some development libraries to compile Python source code. Use the following command to install prerequisites for Python:

sudo apt-get install build-essential checkinstall
sudo apt-get install libreadline-gplv2-dev libncursesw5-dev libssl-dev 
    libsqlite3-dev tk-dev libgdbm-dev libc6-dev libbz2-dev libffi-dev zlib1g-dev

Step 2 – Download Python 3.8

Download Python source code using the following command from python official site. You can also download the latest version in place of specified below.

cd /opt
sudo wget https://www.python.org/ftp/python/3.8.0/Python-3.8.0.tgz

Then extract the downloaded source archive file

sudo tar xzf Python-3.8.0.tgz

Step 3 – Compile Python Source

Use below set of commands to compile Python source code on your system using altinstall.

cd Python-3.8.0
sudo ./configure --enable-optimizations
sudo make altinstall
make altinstall is used to prevent replacing the default python binary file /usr/bin/python.

Step 4 – Check Python Version

Check the installed version of python using the following command. As you have not overwritten the default Python version on the system, So you have to use Python 3.8 as follows:

python3.8 -V

Python-3.8.0

After successful installation remove the downloaded archive to save disk space

sudo rm -f Python-3.8.0.tgz

The post How to Install Python 3.8 on Ubuntu, Debian and LinuxMint appeared first on TecAdmin.

The post How to Install Python 3.8 on Ubuntu, Debian and LinuxMint first appeared on RSSFeedsCloud.

Leave a Comment

Your email address will not be published. Required fields are marked *